تبلیغات

آموزش راه اندازی voip در packet tracer سیسکو

packet-tracer

در این مقاله از سایت تک تیپ قصد داریم تا به صورت گام به گام آموزش راه اندازی voip در packet tracer سیسکو را قرار دهیم تا بتوانید بدون نیاز به تجهیزات فیزیکی ، تجربه خود را افزایش دهید.

Cisco Packet Tracer ، همان طور که از نامش پیداست ، ابزاری است که توسط Cisco توسعه یافته است. این ابزار شبیه سازی شبکه ای را برای پیاده سازی شبکه های ساده و پیچیده ارائه می دهد.

هدف اولیه Cisco Packet Tracer کمک به دانش آموزان برای یادگیری اصول شبکه و توسعه مهارت های خاص فناوری Cisco است. این ابزار نمی تواند جایگزین روترهای سخت افزاری یا سوئیچ ها شود زیرا پروتکل ها فقط در روش نرم افزاری اجرا می شوند. جالب است که این ابزار نه تنها محصولات سیسکو ، بلکه بسیاری از دستگاه های شبکه دیگر شرکت ها را نیز پشتیبانی می کند.

پیشنهاد می کنیم قبل از خواند ادامه این مقاله ، آموزش معرفی شده در لینک زیر را ببینید تا روش راه اندازی voip در packet tracer را نیز بهتر یاد بگیرید. شما با کلیک بر روی لینک زیر به صورت مستقیم به صفحه آموزش ارجاع داده خواهید شد.

مزایای packet tracer سیسکو

راه اندازی voip در packet tracer

همان طور که در بالا اشاره شد این نرم افزار شرکت سیسکو یک محیط عالی برای تمرین طراحی شبکه کامپیوتری بدون نیاز به تجهیزات واقعی است.

با این ابزار قدرتمند شبیه سازی شبکه که توسط شرکت Cisco ایجاد شده است ، تجربه عالی از ساخت و طراحی شبکه خواهید داشت. تمرین ساختن شبکه های ساده و پیچیده در دستگاه های مختلف و فراتر رفتن از روترها و سوئیچ ها ، راه حل های به هم پیوسته برای یادگیری طراحی شبکه است.

از Packet Tracer به عنوان محیط یادگیری برای دوره های آموزشی ، آموزش از راه دور ، آموزش حرفه ای ، برنامه های عملی استفاده می کنند.

یکی از مهم ترین روش های تمرین برای آموزش های CCNA سیسکو استفاده از این نرم افزار است ، کسانی که آموزش CCNA و CCENT را دیده باشند باید برای یادگیری بهتر تمرینات زیادی انجام دهند و تجربه کسب نمایند ، در این مواقع استفاده از این نرم افزار به کمک متخصصان و علاقه مندان به شبکه های کامپیوتری آمده و این خلا را پر می کند.

مهندسان ترجیح می دهند قبل از پیاده سازی ، هر پروتکلی را بر روی Cisco Packet Tracer آزمایش کنند. علاوه بر این ، مهندسانی که می خواهند هرگونه تغییری را در یک شبکه ایجاد نمایند ، ترجیح می دهند ابتدا از Cisco Packet Tracer برای آزمایش تغییرات مورد نیاز استفاده کنند و اگر مطابق انتظار پیش رفت آن را به صورت کامل پیاده سازی نمایند.

در زیر ویژگی های این نرم افزار را به صورت اختصاری بیان می کنیم :

  • امکان اتصال دستگاه های نامحدود
  • آموزش الکترونیکی
  • پیکربندی اقدامات تک نفره / چند نفره
  • محیط کاملا تعاملی
  • تجسم شبکه
  • حالت زمان واقعی و حالت شبیه سازی
  • اکثر پروتکل های شبکه را پشتیبانی می کند
  • پشتیبانی زبان بین المللی
  • سازگاری با اکثر پلتفرم ها

VOIP چیست ؟

VOIP چیست ؟

یکی از جذاب ترین فناوری های روز VoIP می باشد که امکان ارتباط تماس صوتی از طریق اتصال به اینترنت را فراهم می کند. با افزایش پهنای باند ، VoIP به عنوان جایگزین قطعی خدمات تلفن برای مصرف کنندگان و مشاغل تبدیل شده است.

به علت هزینه بسیار پاین آن نسبت به خطوط تلفن ، استقبال زیادی از این پروتوکل شده است و بیشتر شرکت های ایرانی از این سرویس های برای برقراری ارتباط با مشتریانشان استفاده می کنند.

ارائه دهندگان خدمات تلفن ابری شامل ویژگی های قدرتمندی هستند که در سرویس تلفن استاندارد از آن ها بی بهره است. تماس خودکار ، ضبط تماس ، بررسی شناسه تماس گیرنده ، ارسال پست صوتی به ایمیل و موارد دیگر از جمله ویژگی های جذاب VOIP می باشد.

سایت فرادرس یک آموزش کاملا حرفه ای برای علاقه مندان به VOIP تهیه کرده است که به صورت کامل آموزش ساخت تلفن تحت شبکه ویپ را می دهد. برای دسترسی به این آموزش می توانید به لینک زیر مراجعه کنید.

راه اندازی voip در packet tracer

برای انجام این آموزش ما از ورژن 7.3 نرم افزار Packet Tracer استفاده کردیم اما ورژن های مختلف تفاوت های چندانی با هم ندارند و با مشاهده این آموزش به راحتی می توانید ویپ خود را در ورژن ها مختلفی از پاکت تریسر راه اندازی کنید.

این آموزش را از سایت packettracernetwork.com برای شما انتخاب کردیم ، علت آن هم توضیح صریح ، ساده و بی تکلف آن می باشد.

ابتدا دیاگرام شبکه ای که قصد راه اندازی آن را داریم مشاهده کنید.

راه اندازی voip در packet tracer

در این دیاگرام فقط IP تلفن 1 در ابتدای آزمایش وصل است و تلفن IP 2 باید قطع شود. همانطور که در تصویر مشاهده می کنید تلفن 2 را کمی کمرنگ تر از تلفن 1 نمایش داده ایم.

گام اول : پیکربندی رابط FastEthernet 0/0 و سرور DHCP در RouterA (روتر 2811)

برای پیکربندی رابط FastEthernet 0/0 از آدرس IP 192.168.10.1/24 استفاده کنید. فراموش نکنید که رابط را با دستور no shutdown فعال کنید!

RouterA>enable
RouterA#configure terminal
RouterA(config)#interface FastEthernet0/0
RouterA(config-if)#ip address 192.168.10.1 255.255.255.0
RouterA(config-if)#no shutdown

همانطور که می دانید هر تلفن IP متصل به شبکه به یک سرور DHCP نیاز دارد تا آدرس IP و محل سرور TFTP را به آن ارائه دهد. پس باید پیکربندی را با کد های زیر انجام دهید.

RouterA(config)#ip dhcp pool VOICE #Create DHCP pool named VOICE
RouterA(dhcp-config)#network 192.168.10.0 255.255.255.0 #DHCP network network 192.168.10 with /24 mask#
RouterA(dhcp-config)#default-router 192.168.10.1 #The default router IP address#
RouterA(dhcp-config)#option 150 ip 192.168.10.1 #Mandatory for voip configuration.

پس از پیکربندی باید کمی صبر کرده تا دستورات اعمال شود ، سپس برای مطمئن شدن اعمال تغییرات ماوس را روی تلفن( IP Phone 1 ) برده تا خلاصه پیکربندی نمایان شود و با مشاهده آن از انجام پیکربندی اطمینان حاصل کنید.

گام دوم : پیکربندی سرویس تماس تلفنی Express Manager در RouterA

اکنون باید سرویس تلفن Call Manager Express را در RouterA پیکربندی کنید تا VoIP در شبکه شما فعال شود. برای این کار کد های زیر را در برنامه بنویسید.

RouterA(config)#telephony-service #Configuring the router for telephony services#
RouterA(config-telephony)#max-dn 5 #Define the maximum number of directory numbers#
RouterA(config-telephony)#max-ephones 5 #Define the maximum number of phones#
RouterA(config-telephony)#ip source-address 192.168.10.1 port 2000 #IP Address source#
RouterA(config-telephony)#auto assign 4 to 6 #Automatically assigning ext numbers to buttons#
RouterA(config-telephony)#auto assign 1 to 5 #Automatically assigning ext numbers to buttons#

گام سوم : پیکربندی یک vlan صدا در SwitchA

پیکربندی زیر را روی رابط های SwitchA اعمال کنید. این پیکربندی ترافیک صدا و داده را در vlan های مختلف در SwitchA جدا می کند. بسته های داده از طریق دسترسی vlan منتقل می شوند.

SwitchA(config)#interface range fa0/1 – 5 #Configure interface range#
SwitchA(config-if-range)#switchport mode access
SwitchA(config-if-range)#switchport voice vlan 1 #Define the VLAN on which voice packets will be handled#

گام چهارم : پیکربندی شماره تلفن برای IP Phone 1

اگرچه IP Phone 1 را قبلاً به SwitchA متصل کردیم ، اما برای برقراری ارتباط به پیکربندی بیشتری نیاز دارد. برای تعیین شماره تلفن به این آی پی تلفن ، باید RouterA CME را پیکربندی کنید. مطابق زیر کد نویسی انجام دهید.

RouterA(config)#ephone-dn 1 #Defining the first directory entry#
RouterA(config-ephone-dn)#number 54001 #Assign the phone number to this entry#

گام پنجم : بررسی پیکربندی

اطمینان حاصل کنید که IP Phone آدرس IP و شماره تلفن 54001 را از RouterA دریافت می کند. برای اینکار مطابق تصاویر زیر آی پی آدرس و Line Number را چک کنید. همچنین می توانید از قسمت ال سی دی تلفن شماره را بررسی نمایید.

بررسی پیکربندی VOIP

بررسی پیکربندی VOIP

گام ششم : پیکربندی شماره داخلی برای تلفن 2

ابتدا باید IP Phone 2 را به SwitchA متصل کرده و تلفن را با استفاده از آداپتور برق (از تب Physical) روشن کنید. و سپس کد های زیر را برای تلفن 2 وارد نمایید.

RouterA(config)#ephone-dn 2 #Defining the first directory entry#
RouterA(config-ephone-dn)#number 54002 #Assign the phone number to this entry#

گام آخر : بررسی اتصال

پس از پیکربندی این شبکه ویپ باید اتصال این دو تلفن را با هم بررسی کنید برای اینکار باید ابتدا مانند گام پنجم اتصال تلفن 2 به سیستم را چک نمایید.

سپس با استفاده از Phone 2 ، شماره تلفن Phone 1 را که عدد 54001 است را شماره گیری کنید تا مطمئن شوید اتصال برقرار می شود یا خیر. اگر تلفن 1 زنگ خورد که یعنی پیکربندی را با موفقیت به انجام رسانده اید. اما اگر تلفن زنگ نخورد دوباره مراحل را بررسی کنید تا اشکال کار خود را متوجه شوید. ( که احتمالا به علت اشتباه نوشتن دستورات خواهد بود.

این مثال بسیار ساده فقط برای راه اندازی voip در packet tracer سیسکو برای اتصال دو تلفن به هم می باشد ، برای اتصال و راه اندازی شبکه VOIP با تعداد تلفن های بالا و دیاگرام های مختلف نیز باید چنین مراحلی را انجام دهید. اما باید اموزش شبکه کامپیوتری را پشت سر گذاشته باشید تا اتصالات دقیق و درستی بین دستگاه های شبکه ایجاد کنید.

اگر به مبحث شبکه های کامپیوتری علاقمندید و دوست دارید در این باره بیشتر بدانید، آموزش ارائه شده در لینک زیر مناسب شماست.

امنیت شبکه های VOIP

امنیت شبکه های VOIP

یکی از مهم ترین بخش های راه اندازی شبکه های VOIP تامین امنیت آن می باشد. احتمال رخ دادن مواردی همچون شنود ، هک شدن و … در شبکه های VOIP بالا است از این رو در هنگام راه اندازی voip در packet tracer سیسکو نیز باید به این نکته بسیار توجه داشته باشید.

سایت فرادرس مجموعه بسیار گسترده ای از آموزش های امنیت شبکه را فراهم نموده است که می توانید از این آموزش ها برای هزچه ایمن تر کردن شبکه های VOIP خود استفاده کنید. در این مجموعه آموزش های زیادی همچون تست نفوذ ، افزایش امنیت شبکه ، انواع روش های هک ، روش های مقابله با هک و … را پیدا خواهید نمود.

در زیر لینک مربوط به این مجموعه را قرار می دهیم تا بتوانید با استفاده از این آموزش ها که توسط بهترین اساتید کشور تهیه شده است. امنیت شبکه های خود را بیشتر کرده و جلوی شنود ها و هک های احتمالی را بگیرید.

تبلیغات

ارسال دیدگاه

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *