تبلیغات

آموزش گام به گام راه اندازی ikev2 در میکروتیک

mikrotik-ikev2

راه اندازی ikev2 در میکروتیک به شما امکان می دهد محتویات محدود جغرافیایی و همچنین ترافیک ناشناس و ایمن اینترنت را از دستگاه های متصل به روتر خود مسدود کنید.

در این مقاله از سایت تک تیپ قصد داریم تا به صورت گام به گام نحوه کانفیگ کردن این پروتکل را برای روتر های میکروتیک آموزش دهیم.

پروتکل های IKE و IKEv2 چیست؟

Internet Key Exchange یا IKE یک پروتکل تونل زنی مبتنی بر IPSec است که یک کانال ارتباطی VPN امن را فراهم می کند و مذاکره و احراز هویت خودکار را برای IPSec SA به شیوه ای مطمئن تعریف می کند.

اولین نسخه از این پروتکل VPN (IKEv1) در سال 1998 معرفی شد و نسخه دوم (IKEv2) 7 سال بعد منتشر شد.

اگر می خواهید با انواع پروتکل های امن آشنا شوید یک آموزش کاملا حرفه ای برایتان سراغ داریم که لینک آن را برایتان قرار دادیم.

ویژگی های پروتکل IKEv2

چرا از IKEv2 استفاده کنید:

  • رمزگذاری داده های 256 بیتی
  • IPSec را برای امنیت پیاده سازی می کند
  • اتصال پایدار و ثابت
  • پشتیبانی از MOIKE که سرعت بهتر را تضمین می کند

امنیت : IKEv2 از گواهی احراز هویت سرور استفاده می کند ، به این معنی که تا زمانی که هویت درخواست کننده تشخیص داده نشود ، اقدامی انجام نخواهد شد. این ویژگی از حملات DDOS پیشگیری خواهد نمود.

سرعت : معماری پیچیده و سیستم پیام رسانی کارآمد IKEv2 می تواند عملکرد را بهبود بخشد. علاوه بر این ، سرعت اتصال آن به طور قابل توجهی سریعتر است ، به ویژه به دلیل پیمایش NAT داخلی ، که به طور قابل توجهی عبور از فایروال ها و برقراری اتصال را سرعت می بخشد.

نکات مثبت پروتکل IKEv2

  • سریعتر از PPTP و L2TP
  • از روش های رمزگذاری با کیفیت بالا پشتیبانی می کند
  • پایداری بالا
  • پشتیبانی از تلفن
  • راه اندازی آسان

نکات منفی پروتکل IKEv2

شاید تنها نکته منفی این پروتکل استفاده از پورت UDP 500 باشد که باعث مسدود شدن برخی فایروال ها خواهد شد.

آموزش راه اندازی ikev2 در میکروتیک

این راهنما نحوه تنظیم روتر Mikrotik با استفاده از پروتکل IKEv2 را به شما نشان می دهد. به این ترتیب ، می توانید از همه دستگاه های متصل به روتر به طور همزمان محافظت کنید.

1- پیدا کردن مشخصات ورود

برای اتصال به VPN با استفاده از پیکربندی دستی IKEv2 ، به اعتبارنامه خدمات Surfshark خود نیاز دارید. توجه داشته باشید که اعتبار سرویس Surfshark شما با اعتبار حساب Surfshark شما ، یعنی آدرس ایمیل و رمز عبور شما متفاوت است.

در اینجا نحوه پیدا کردن اعتبار Surfshark آورده شده است:

  1. به این صفحه بروید ، جایی که می توانید تمام جزئیات مورد نیاز برای اتصال دستی را بیابید.
    (ممکن است لازم باشد قبل از رفتن به این صفحه وارد سیستم شوید. در این حالت ، آدرس ایمیل و گذرواژه خود را وارد کنید ، سپس روی ورود کلیک کنید.)
  2. روی برگه اعتبارنامه در بالا کلیک کنید. مدارک Surfshark خود را در آنجا پیدا خواهید کرد.

IKEv2

2- انتخاب سرور Surfshark

هر سرور دارای یک نام میزبان است که روتر شما باید از آن برای اتصال به یک سرور خاص استفاده کند.

برای یافتن لیستی از همه سرورها و نام میزبان آن ها مطابف تصویر ، به قسمت Files بروید.

شما به نام میزبان سرور VPN نیاز دارید. نام میزبان در زیر نماد پرچم برای هر کشور قرار دارد. هنگام اتصال به لهستان ، نام میزبان سرور لهستان-ورشو یا لهستان-گدانسک را کپی کنید. اگر می خواهید به فنلاند متصل شوید ، سرور هلسینکی را که نام میزبان فنلاندی است کپی کنید.

انتخاب سرور Surfshark

3- دانلود گواهی نامه IKEv2

میکروتیک برای اتصال به یک فایل گواهی IKEv2 نیاز دارد.

همانند مرحله انتخاب سرور Surfshark در قسمت Files وارد شده و به سمت پایین اسکرول کرده تا سایر فایل های پیکربندی را مشاهده نمایید. ( مطابق تصویر زیر )

دانلود گواهی IKEv2

سپس از دکمه سمت راست می توانید گواهی نامه مورد نظر را دانلود نمایید.

4- راه اندازی IKEv2 در میکروتیک

در این مرحله باید به خوبی با سیستم عامل میکروتیک آشنا باشید تا به سرعت برگه ها و تب های مورد نیاز را پیدا کنید. اگر با سیستم عامل میکروتیک کار نکردید ، نگران نباشید سایت فرادرس در یک آموزش ویدیویی کامل حدود 50 دقیقه ای ، به صورت رایگان تمام قسمت های این سیستم عامل را معرفی کرده و آموزش های لازم را می دهد. شما نیز به راحتی با مراجعه به صفحه آموزش آشنایی با سیستم عامل میکروتیک MikroTik در سایت فرادرس می توانید پس از ثبت نام، به صورت رایگان آن را مشاهده نمایید.

1- با وارد کردن آدرس IP روتر در نوار URL مرورگر خود ، تنظیمات روتر خود را باز کنید.

راه اندازی IKEv2 در میکروتیک

2- روی Files و سپس Upload کلیک کنید.

راه اندازی IKEv2 در میکروتیک

3- از مرحله دانلود گواهی نامه IKEv2 ، به پوشه ای بروید که در آن گواهی IKEv2 را دارید. فایل گواهی را انتخاب و باز کنید کنید.

راه اندازی IKEv2 در میکروتیک

4- به System> Certificates بروید.

راه اندازی IKEv2 در میکروتیک

5- روی دکمه Import کلیک کنید. منوی کشویی را در پنجره جدید باز کنید و گواهی IKEv2 را انتخاب کنید. روی Import کلیک کنید.

راه اندازی IKEv2 در میکروتیک

گواهی وارد شده را در اینجا مشاهده خواهید کرد.

6- حالا یک ترمینال جدید باز کنید.

 

راه اندازی IKEv2 در میکروتیک

7- دستور زیر را برای ایجاد یک فایل پیکربندی جدید وارد کنید:

/ip ipsec profile
add name=FRBD

ما اسم این نماییه را برابر با FRBD قرار دادیم ، این نام فرضی است و شما هر نامی می توانید قرار دهید.

راه اندازی IKEv2 در میکروتیک

8- دستورات زیر را برای ایجاد پیشنهاد جدید وارد کنید:

/ip ipsec proposal
add name=FRBD pfs-group=none

راه اندازی IKEv2 در میکروتیک

توجه داشته باشید اگر نام دیگری برای نماییه انتخاب کردید باید در دستور بالا به جای FRBD قرار دهید.

یکی از موارد که در طراحی های شبکه های مبتنی بر تجهیزات میکروتیک مورد نیاز می باشد ، شناخت کامل روتربرد های این شرکت است ، یکی از بهترین آموزش هایی که برای آشنایی با روتربرد های میکروتیک تهیه شده است در زیر معرفی شده است. با کلیک بر روی لینک زیر به راحتی می توانید از این آموزش حرفه ای استفاده کنید.

9- دستور زیر را برای افزودن policy group وارد کنید:

/ip ipsec policy group
add name=FRBD

راه اندازی IKEv2 در میکروتیک

10- با وارد کردن این دستور یک policy جدید ایجاد کنید:

/ip ipsec policy
add dst-address=0.0.0.0/0 group=FRBD proposal=FRBD src-address=0.0.0.0/0 template=yes

راه اندازی IKEv2 در میکروتیک

11- در این مرحله باید دستور زیر را برای ایجاد حالت پیکربندی جدید وارد کنید:

/ip ipsec mode-config
add name=FRBD responder=no

راه اندازی IKEv2 در میکروتیک

12- سپس دستورات زیر را برای افزودن peer وارد کنید:

/ip ipsec peer
add address=fr-bod.prod.surfshark.com exchange-mode=ike2 name=FRBD profile=FRBD

شما باید نام مکانی را که می خواهید استفاده کنید وارد کنید. شما این مرحله را در مرحله انتخاب سرور Surfshark انتخاب کرده اید. بنابراین fr-bod.prod.surfshark.com را با مکانی که می خواهید به آن متصل شوید جایگزین کنید.

راه اندازی IKEv2 در میکروتیک

13- اکنون باید هویت جدیدی ایجاد کنید. این کار به صورت دستی راحت تر از ترمینال است ، بنابراین ترمینال را ببندید و به آدرس IP -> IPsec بروید.

راه اندازی IKEv2 در میکروتیک

14- برگه Identity را باز کنید ، روی علامت مثبت آبی رنگ کنید و پنجره Identity را مطابق تصویر زیر پر کنید.

راه اندازی IKEv2 در میکروتیک

اکنون به اعتبارنامه خدمات Surfshark که در ابتدای این آموزش جمع آوری کرده اید نیاز خواهید داشت.

Perr: FRBD
Auth. Method: eap
EAP Methods: MS-CHAPv2
Certificate: گواهی IKEv2 را که دانلود کردید انتخاب کنید.
Remote Certificate: none
Username: یوزرنیم Surfshark را که در گام اول پیدا کردیم وارد کنید .
Password: پسورد Surfshark را وارد کنید.
Policy Template Group: FRBD
Notrack Chain: خالی بگذارید
My ID Type: auto
Remote ID Type: auto
Match By: remote id
Mode Configuration: FRBD
Generate Policy: port strict

بر روی Apply و سپس Ok کلیک کنید و پنجره را ببندید.

15- در این مرحله باید تصمیم بگیرید که چه چیزی را می خواهید از طریق وی پی ان ارسال کنید. شما می توانید فط روتر و یا همه دستگاه های متصل به شبکه را انتخاب نمایید.

برای فعال کردن همه دستگاه ها از طریق VPN ، باید یک فایروال برای محدوده IP در این شبکه تنظیم کنید. در مثال ما ، محدوده IP 192.168.10.0/24 است ، بنابراین برای اینکه اجازه دهیم همه دستگاه های متصل به روتر Mikrotik از تونل VPN عبور کنند ، از دستور زیر استفاده می کنیم:

/ip firewall address-list
add address=192.168.10.0/24 list=local

لطفاً توجه داشته باشید که دامنه آدرس های IP در شبکه شما متفاوت خواهد بود.

به عنوان مثال ، اجازه دهید از آدرس IP داخلی رایانه متصل به این روتر استفاده کنیم. آدرس IP این رایانه 192.168.10.254 است

یک ترمینال جدید باز کنید و از دستور زیر استفاده کنید:

/ip firewall address-list
add address=192.168.10.254 list=local

راه اندازی IKEv2 در میکروتیک

16- در مرحله بعد ، باید لیست آدرس فایروال را به حالت پیکربندی اختصاص دهید.

از دستور زیر استفاده کنید.

/ip ipsec mode-config
set [ find name=FRBD ] src-address-list=local

راه اندازی IKEv2 در میکروتیک

شما اکنون رایانه خود را به یک سرور خاص Surfshark VPN متصل کرده اید

17- برای اطمینان از موفقیت آمیز بودن اتصال ، وب سایت ipleak.net را باز کنید و ببینید آیا می توانید آدرس IP و DNS سرور Surfshark را مشاهده کنید.

راه اندازی IKEv2 در میکروتیک

با انجام این 17 مرحله به راحتی می توانید راه اندازی ikev2 در میکروتیک را بدون داشتن دانش شبکه انجام دهید.

نصب ikev2 در میکروتیک

همانطور که در بالا توضیح دادیم نصب و راه اندازی ikev2 در میکروتیک بسیار ساده است و دانش زیادی نیاز نخواهد داشت و با پیروی از روش گام به گام بالا می توانید به راحتی ، پیکربندی این پروتکل را در شبکه های میکروتیکی انجام دهید ، با این حال یکی از مهم ترین مهارت هایی که باید یک متخصص شبکه های میکروتیک بلد باشد. آشنایی کامل با شبکه های کامپیوتری و شناخت مفاهیم مربوط به آن می باشد.

در ادامه دو منبع بسیار عالی برای علاقه مندان به شبکه های کامپیوتری را قرار می دهیم تا به راحتی به جدید ترین و بروز ترین دانش شبکه های کامپیوتری و امنیت شبکه های کامپیوتری دسترسی داشته باشید.

این منابع هر چند وقت بروز می شوند و آموزش دانش های جدید حوزه شبکه و امنیت را تهیه و تولید می کنند. با مراجعه به این صفحات سایت فرادرس می توانید جدید ترین منابع آموزشی دنیا را در اختیار داشته باشید.

 

 

تبلیغات

ارسال دیدگاه

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

*

code